Unscheduled maintenance
Incident Report for Award Force
Resolved
The Award Force application has been fully restored.
Posted 8 months ago. Sep 27, 2017 - 01:19 AEST
Investigating
There is a known server issue due to which the maintenance page is currently being shown. The Award Force application will be back as soon as this has been resolved. We appreciate your patience.
Posted 8 months ago. Sep 27, 2017 - 01:07 AEST