Navigation issues
Incident Report for Award Force
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 12, 2018 - 12:08 AEST
Identified
We're aware of issues some customers are experiencing in respect to application navigation. We have identified the problem and will have a fix out shortly.
Posted 4 months ago. Jun 12, 2018 - 11:16 AEST
This incident affected: Award Force application.