Registration issues
Incident Report for Award Force
Resolved
This incident has been resolved.
Posted 8 days ago. Jul 10, 2018 - 16:59 AEST
Identified
We're aware of problems with registration some users are currently experiencing and have identified the issue. We will have a solution deployed very soon.
Posted 8 days ago. Jul 10, 2018 - 16:03 AEST
This incident affected: Award Force application.