Experiencing server issues
Incident Report for Award Force
Resolved
All systems have now been restored.
Posted 10 months ago. Jan 26, 2018 - 04:43 AEDT
Investigating
There is a known server issue at the moment which is causing some parts of the system to be extremely slow or unresponsive. We are investigating on the highest priority. Thank you for your patience.
Posted 10 months ago. Jan 26, 2018 - 04:05 AEDT