Unexpected outage
Incident Report for Award Force
Resolved
This incident has been resolved.
Posted Dec 09, 2019 - 13:21 AEDT
Investigating
We are currently experiencing an unexpected outage. We are investigating the cause and will have updates shortly.
Posted Dec 09, 2019 - 13:20 AEDT
This incident affected: Award Force application.