We are currently experiencing continued disruptions to our UAE infrastructure, which may affect your ability to access accounts in the region. Our team is actively investigating alternative solutions. We apologise for the inconvenience and appreciate your patience.
Posted Mar 02, 2026 - 08:23 UTC
Monitoring
Connection has been restored. Accounts in the UAE are now accessible again. We continue to monitor the situation.
Posted Mar 01, 2026 - 19:33 UTC
Investigating
Our infrastructure has been affected by the developing situation in the Middle East. Accounts hosted in the UAE are currently inaccessible. We are investigating possible workarounds.