Issue with manager bulk downloads

Incident Report for Award Force

Resolved

The issue affecting downloads has been resolved. Thank you for your patience.
Posted Mar 09, 2023 - 10:09 UTC

Update

We are continuing to work though the issue.
Posted Mar 09, 2023 - 07:19 UTC

Identified

We're aware of and currently investigating an issue with downloads. While that is happening, we have disabled the feature until we implement a fix.
Posted Mar 09, 2023 - 02:54 UTC
This incident affected: Award Force application.