Issues accessing application

Incident Report for Award Force

Resolved

The 3rd party bot detection tool has announced the issue has been resolved. Please refresh your browser and try again.
Posted Mar 03, 2025 - 12:26 UTC

Identified

We are aware that some users are being prevented from accessing the application due to our bot detection tool. The provider of the tool is aware of the issue and is implementing a fix.
Posted Mar 03, 2025 - 11:53 UTC
This incident affected: Award Force application.