Outgoing mail errors

Incident Report for Award Force

Resolved

This incident has been resolved.
Posted Sep 09, 2021 - 10:56 UTC

Investigating

There's currently an issue with our email provider preventing some emails from reaching their intended destination. We are waiting on an upstream update and fix.
Posted Sep 09, 2021 - 07:13 UTC
This incident affected: Email outbound delivery.