Known issues with slowness and some tasks failing/timing out
Incident Report for Award Force
Resolved
We identified the issue and applied a fix. The system is back to normal. Thank you for your patience.
Posted Jan 11, 2024 - 18:45 UTC
Investigating
We are aware of some users experiencing slowness in using Award Force, including pages like payments not working as expected. We are working towards a resolution as our top priority. Thank you for your patience and understanding.
Posted Jan 11, 2024 - 15:28 UTC
This incident affected: Award Force application.